Fungus infested Nikon D50 sensor (before cleaning).


5 comments so far...

helen birch plus November 11, 2010, 08:36 PM
fungus or dust/fibre?
seeyar November 12, 2010, 09:12 AM
No way so much dust/fiber can get in there. Lens/CCD fungus problem is pretty common here due to high humidity.
helen birch plus November 12, 2010, 03:31 PM
eek :-(
Paulo Brabo Team 23 November 13, 2010, 10:07 AM
Also here 8-|

Did you do the cleaning yourself?

seeyar November 13, 2010, 02:06 PM
Yes, did it myself. Folded a piece of lint free cloth to fit in the CCD cavity, held with tweezer, wet with methanol and rubbed gently. It took me around 2 hours, because the dirt get pushed around instead of getting removed. The lint free cloth occasionally dropped some lint too. Make sure it is wet with methanol and repeat with fresh cloth.
Add a comment...
Your name:
Your e-mail:





About 23

About 23
What is 23 and who's behind the service?
Just In
Discover the world from a different angle.
Here's a crop of the latest photos from the around the world.
Search
Search photos from users using 23
Help / Discussion
Get help or share your ideas to make 23 better
23 Blog / 23 on Twitter
Messages and observations from Team 23
Terms of use
What can 23 be used for and what isn't allowed
More services from 23
We also help people use photo sharing in their professional lives
  • Basque (ES)
  • Bulgarian (BG)
  • Chinese (CN)
  • Chinese (TW)
  • Danish (DK)
  • Dutch (NL)
  • English (US)
  • French (FR)
  • Galician (ES)
  • German (DE)
  • Italian (IT)
  • Norwegian (NO)
  • Polish (PL)
  • Portuguese (PT)
  • Russian (RU)
  • Spanish (ES)
  • Swedish (SE)

Popular photos right now

See also